12 Jun 2015

Gradle Please

Hello!

Every android developer faced the problem when you are adding some dependency to your build.gradle or maven file and sometimes you can't find latest version of some library and this dependency can't be resolved.

dependencies {   
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:22.2.0'
    compile 'com.google.android.gms:play-services:7.5.0'
    compile 'io.segment.analytics.android:flurry:1.3.1'
    compile 'com.j256.ormlite:ormlite-android:4.48'
    compile 'com.j256.ormlite:ormlite-core:4.48'
    //compile 'com.actionbarsherlock:actionbarsherlock:4.4.0@aar'
    compile 'com.googlecode.json-simple:json-simple:1.1.1'
    compile 'org.mozilla:rhino:1.7.6'
    compile 'junit:junit:4.12'
}  

I have good news for those who struggled with it!

Here is great website

Now it will be easy to add dependencies to your project

P.S. But still it's better to read library documentation and use the recommended version of the lib

blog comments powered by Disqus